Still need HELP with vat <-> reflecter <-> CUSEEME

Hugh Anderson (h_anders@ee.cit.ac.nz)
Fri, 10 Feb 1995 04:13:24 -0500


Hi again...

I have been having trouble setting up two-way vat<->CUSEEME audio
conversations. The MAC will send ok to UNIX/vat, but it doesn't hear
any UNIX/vat audio.

I removed the VAT UNICAST line in the configuration file for the reflector,
as David suggested, but still no joy :-(

I have examined the reflector log files and I now think that the reflector
is not retransmitting the multicast vat audio to the MAC.

Here is what I have been doing.....

1. I start a reflector with the following config file on machine REFLECT:

SELF-REFLECT
CONF-ID 0 Test Of Conference
//
NV-MC-PORT 7654
NV-MC-OUT 15 224.2.1.1
VAT-MC-PORT 6543
VAT-MC-IN 224.2.2.1
VAT-MC-OUT 16 224.2.2.1
VAT-CONF-ID 0

2. On a UNIX machine, I use sd to create an nv/vat session with
the specified multicast address, port numbers and ids (both 0)

3. On the UNIX machine I open the session, and get vat and nv windows.
The reflect log displays:
**log: New maven client (UNIX machine id)
**log: Maven id sendto error

4. On a MAC, I start CUSEEME, and connect to machine REFLECT. The video
from the MAC comes back to the MAC, and appears in the UNIX nv window.
(Incidentally .... If I remove the self-reflect line from the
configuration file, I lose both the MAC returned feed (expected) and
the UNIX/nv video from the MAC! ???????) Any explanations for this?

5. If I talk on the MAC, I can hear it on the UNIX machines. The reflect
log displays:
**log: MAC speaking
**log: Maven sendto error in distribute.
**log: ...... Pkts in 86, Pkts out 84 (and so on)

6. If I talk on UNIX (vat), all the vat machines can hear the audio,
but not the MAC. A packet grabber shows no traffic from the REFLECT
machine to the MAC. The reflect log shows:
**log: UNIX speaking
**log: ....... Pkts in 105, Pkts out 21 (and so on)

Each of the machines appears to know about the others... If I run refmon
to REFLECT, the 'maven' command reports that I have a VAT client (the
UNIX machine), and the 'who' command reports that I have the CUSEEME
MAC client.

>From all of this, I believe that the reflect software (30b03) is not
retransmitting the UNIX/vat multicast audio down to the MAC.

Can someone tell me why, or show me how to configure this stuff?

cheers Hugh

*-----------------------------------------------------------------*
| Hugh Anderson EMAIL: hugh@ee.cit.ac.nz |
| CIT Heretaunga, NZ URL: http://www.ee.cit.ac.nz/~h_anders/ |
*-----------------------------------------------------------------*