Re: audio problems

Robert Hsiung (dr-bob@uchicago.edu)
Thu, 18 Jan 1996 08:00:33 -0600


At 10:50 PM 1/12/96, Jim Kowalczyk wrote:

>I've gotten the program to recieve the video portion of broadcasts
>but I cannot receive any audio. I have a Mac Performa 450 and
>connect to a slip account using a 28.8 modem. I'm not transmitting
>vidio because I've yet to purchase a camera, is this the reason I
>cannot recieve audio? Please Help!

Maybe this will help (maybe not):

From: Tim_Dorcey@cornell.edu
Date: Tue, 16 Jan 1996 16:33:45 -0500
Subject: Re: correction for README.reflector.4.00b3.txt

>1. I've had people connect to my reflector and not been able to hear them.
>Other people I've heard just fine.

The reflector has outgoing rate control algorithms by which it adjusts
outgoing data rates to each recipient according to observed packet loss.
When the outgoing rate cap gets below what is required for a given audio
encoding, all audio packets are dropped. So, e.g., if they were
transmitting the 32 kbps Intel DVI audio, and the reflector decided that
your connection could only handle 16 kbps, you would get none of it,
instead of half of the packets. A problem with the current algorithm is
that in order to assess the capacity of your connection, the reflector must
have some data to test it with. If you are receiving only audio, it would
send none of it, and never realize that it could get through. As long as
you are receiving some video, there should be enough data to push the
capacity of the connection above the audio threshold. This will be fixed
in a subsequent reflector.

>My last thought was whether b2 vs. b3 makes a difference...

It might. The main difference is that b3 automatically slows down the
video when audio is outgoing, but if the reflector is killing the audio
based on the all or none logic described above, b3 would take longer to
push the reception cap up.