Re: Problems in the reflector interaction with VAT

Brian O'Shea (boshea@wpine.com)
Tue, 07 Nov 1995 16:44:10 -0500


>
>Hi all,
>
>I'm trying to install a reflector here at the RCCN's Network Management Center.
>The reflector works fine for the normal operation but I'm not able to put it
>in communication with VAT. I can send audio to VAT but I don't receive audio
>from VAT. I tryed either mulicast and unicast mode with no results.
>
>In multicast mode I get the following output when I run the reflector:
>
>recvfrom error on msg_sock : Invalid argument: FATAL ERROR: EXITING
>The configuration I use is:
>
>VAT-MC-PORT 3456
>VAT-MC-IN 224.2.0.1
>VAT-MC-OUT 16 224.2.0.1
>VAT-CONF-ID 0
>
>In Unicast mode I use the following configuration:
>VAT-UC-PORT 3456
>VAT-CONF-ID 0
>
>I can see the reflector and CUSM clients on the VAT console, I can hear their
>audio but they can't hear audio sent by VAT.
>
>Does somebody have an idea of what I must do ?
>
>BTW, I'm in a Solaris 2.4 environment.
>
>Thanks in advance,
>

Are you running the reflector on the same host that you are running VAT on?
If the answer is yes, the solution is, don't do that. :-) Since the
reflector and VAT use UDP with port number 3456, and since UDP is
connectionless, you can't both be sending and receiving on that port on the
same host at the same time.

If you are using 2 different hosts, then I would try using the audio tools on
your solaris to verify that the microphone is working.

-bos

+***********************************************************************+
+ Brian O'Shea White Pine Software +
+ Network/OS Software Engineer 15 Messenger Square +
+ boshea@wpine.com Suite 8A +
+ Fax 508-695-2378 Plainville MA, 02762 +
+ All it takes is all you've got. +
+***********************************************************************+