Using loopback w/ CUSeeMe

Sgt Daniel W. Erskine (derskine@safb.af.mil)
Thu, 30 Nov 1995 10:53:37 -0600 (CST)


Greetings:
I've been subscribed to this LISTSERVER for God-knows-how-long, and
I've noticed a large volume of questions concerning such things as:

1. Full duplex audio, and why we cannot use it.

2. Why I don't receive a video image.

3. Can CUSeeMe operate with NetCOM, AOL & Prodigy.

4. How I can find out if I'm sending a video signal.

5. Can I connect directly to another workstation, etc...?

While perusing through my "CUSeeMe" Email folder, I saw remembered
seeing this message:

On Fri, 13 Oct 1995, Todd Richard Lyons wrote:
> On Thu, 12 Oct 1995, Yoda wrote:
>
> > I would like to have a list of all these nudity reflectors so that I
> > might conduct some research of my own and possibly determine the impact
> > of these nudity reflectors on the cyberculture. By the way...is there
> > audio too?
> >
> > Yoda.
> >
> Drop your pants, stand in front of your cam, and connect to 127.0.0.1
>

Here's the thought. Connecting to the address "localhost" or 127.0.0.1
as a reflector sight, will just connect (looping back) to yourself! This
should provide vital troubleshooting information to even the novice user of
CUSeeMe such as:

1. Determining if there's a proper WinSock connection. Without it,
CUSeeMe won't run at all!

2. Playback of video images to verify capture board compatability,
and configuration.

3. Playback of audio to verify a fully duplex capatable sound card,
and proper sound driver configuration. Most speaker drivers I've
used do not work at all! Sorry, folks...

Now for the "guru" power questions. Keeping the previous in mind, could
2 workstations directly "conceivably" connect to each other, without a
reflector? I've seen this question go unanswered! This should work
because I also connected to my own IP address (vice 127.0.0.1) WITHOUT
using a reflector site!
I have no sound card or video input source (at work) to perform the actual
test on. So could somebody else out there in the CUSeeMe community try this
out and let us know how they faired??? I tried to "loopback" my audio,
using a SB16-ASP card. I'm shown as a lurker with audio capability, yet
I cannot here any full duplex audio (must be the CUSeeMe software?!?).
Does anyone know where I can get a speaker driver compatable with the
Media Control Interface [MCI] specification? Maybe CUSeeMe will work
with this type of speaker driver?
I hope this helps answer some questions, as well as stimulate a few more!!!

Thank you all for your time,
[=============================================================================]
"THERE IS NO SANITY... Just organized CHAOS!!!"

Sgt Daniel W. Erskine "derskine@apci.net"
PHONE: (618) 256-6891 "derskine@caesar.safb.af.mil"
[=============================================================================]