Re: Reflector on Solaris 2.3 -Reply

Lisa M. Frye (frye@kutztown.edu)
Sun, 23 Oct 1994 10:29:46 -0400


Dick,

I compiled version 2.40b3 and 2.40b4 on solaris 2.3. I used the gcc
compiler with CFLAGS=-g -DDEBUG -DMULTI and LFLAGS=-lsocket -lnsl. I
also added the following to reflect.h:
#define MAXHOSTNAMELEN 256
#define bcopy(src,dest,len) (memmove((dest), (src), (len)))
#define bzero(dest,len) (memset((dest), (char)0, (len)))
#include <sys/sockio.h>

After this modification, it compiled and runs quite well. I had also
compiled version 2.40b1 and 2.40b2. Version 2.40b1 did a core dump
everytime I ran it. Version 2.40b2 did a core dump if I ran it with my
own config file instead of letting it use all the defaults.

Hope this helps. We enjoy having our reflector.

Lisa Frye frye@kutztown.edu
Network Software Specialist LMS Annex Room 105
Kutztown University phone: 610-683-4474
Kutztown, PA. 19530 fax: 610-683-4634

"You can bring a person to the university, but you can't make him think."

On Fri, 21 Oct 1994, Dick Dramstad wrote:

> On Mon, 3 Oct 1994, Lisa M. Frye wrote:
> > I am trying to setup a reflector on a SPARCserver 1000 running
> > Solaris 2.3. It compiled fine but core dumps when I try to run
> > it. Is anyone running the reflector on Solaris 2.3? What ports do
> I
> > need to setup in /etc/services? TIA for any help!
>
> To which Borre Ludvigsen <borrel@hiof.no> - @ 10/4/94 6:24 AM
> replied:
> >
> >You might want to see
> http://pipkin.lut.ac.uk/~ben/video/cuseeme.html
> > for a quick guide on making it work.
>
> However, I still can't make the latest (2.0b4) compile under 2.3.
> The tips on
> pipkin are for nv. Direct question: what include file changes and/or
> Makefile
> settings are necessary to get this reflector to run on Solaris 2.3?
> With and
> without Multicast?
>
> Thanks,
> Dick Dramstad
>
>
>